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DISCLAIMER
CONSIDERABLE TIME, EFFORT AND EXPENSE HAVE GONE INTO THE DEVELOPMENT AND TESTING OF
THIS SOFTWARE. HOWEVER, THE USER ACCEPTS AND UNDERSTANDS THAT NO WARRANTY IS EXPRESSED
OR IMPLIED BY THE DEVELOPERS OR THE DISTRIBUTORS ON THE ACCURACY OR THE RELIABILITY OF THIS
PRODUCT.
THIS PRODUCT IS A PRACTICAL AND POWERFUL TOOL FOR STRUCTURAL DESIGN. HOWEVER, THE USER
MUST EXPLICITLY UNDERSTAND THE BASIC ASSUMPTIONS OF THE SOFTWARE MODELING, ANALYSIS,
AND DESIGN ALGORITHMS AND COMPENSATE FOR THE ASPECTS THAT ARE NOT ADDRESSED.
THE INFORMATION PRODUCED BY THE SOFTWARE MUST BE CHECKED BY A QUALIFIED AND
EXPERIENCED ENGINEER. THE ENGINEER MUST INDEPENDENTLY VERIFY THE RESULTS AND TAKE
PROFESSIONAL RESPONSIBILITY FOR THE INFORMATION THAT IS USED.
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Introduction
This document describes how to exchange Building Information Modeling (BIM) data between
Revit 2019 and ETABS 2015 or later, SAP2000 v17 or greater, and SAFE 2014 or later.
This document includes three sections. The first section reviews data exchange between Revit
and ETABS. The second section reviews data exchange between Revit and SAP2000. The third
section reviews data exchange between Revit and SAFE.
Data exchange between Revit and ETABS supports four different workflows:
1) Exporting from Revit to create a new ETABS model.
2) Exporting from Revit to update an existing ETABS model.
3) Importing from ETABS to create a new Revit project.
4) Importing from ETABS to update an existing Revit project. In this case, you may
choose to update locations, designs, or both.
Data exchange between Revit and SAP2000 supports two different workflows:
1) Exporting from Revit to create a new SAP2000 model.
2) Exporting from Revit to update an existing SAP2000 model. SAP2000 v17.2.0 or
later is required.
3) Importing from SAP2000 to create a new Revit project.
4) Importing from SAP2000 to update an existing Revit project. In this case, you may
choose to update locations, designs, or both. SAP2000 v17.2.0 or later is required.
Data exchange between Revit and SAFE supports four different workflows:
1) Exporting from Revit to create a new SAFE model.
2) Exporting from Revit to update an existing SAFE model.
3) Importing from SAFE to create a new Revit project.
4) Importing from SAFE to update an existing Revit project. In this case, you may
choose to only update locations, only update designs, or update both.

4

The flow of information is represented in the schematic below:

Export from Revit to create a new ETABS, SAP2000 or SAFE model.
Export from Revit to update an existing ETABS or SAFE model.

ETABS®, SAP2000® or SAFE®
Revit® Structure

Import from ETABS, SAP2000 or SAFE to create a new Revit
project.
Import from ETABS, SAP2000 or SAFE to update an existing
Revit project.
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Revit and ETABS Data Exchange
Data exchange between CSiXRevit and ETABS supports four different workflows:
1) Exporting from Revit to create a new ETABS model.
2) Exporting from Revit to update an existing ETABS model.
3) Importing from ETABS to create a new Revit project.
4) Importing from ETABS to update an existing Revit project.

Supported Workflows
Exporting from Revit to create a new ETABS model
The table below provides an overview of the data imported in ETABS when exporting from Revit
to create a new ETABS model:
Action
Creation of…

Project Element

Supported

Grid Lines
Story Levels
Materials
Structural Columns and
Structural Framing

Notes

Transfers geometry, offsets, end releases, and
beam and brace alignment points into ETABS.
Imports columns based on splice information
in ETABS.

Steel Column and
Framing Family Types

Creates and maps equivalent ETABS frame
sections. Makes Auto-Select Lists in ETABS for
all families used in the Revit project.
Creates and maps equivalent ETABS frame
sections.
Slanted or warped walls not imported.
Creates and maps equivalent ETABS wall
sections.

Concrete Column and
Framing Family Types
Walls
Wall Family Types
Wall Openings
Floors

Sloped floors with more than four outer
corners are projected on a horizontal plane.
Creates and maps equivalent ETABS slab and
deck sections.

Floor Family Types
Floor Openings
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Footings

Creates fixed joint restraints in ETABS
wherever a footing occurs in Revit.

Point Loads
Line Loads
Area Loads
Load Cases

Non-uniform area loads not imported.
Creates both an ETABS load pattern and load
case for each Revit load case.

Load Combos

Grids
The following Grid attributes are created in ETABS:
• Grid Name: The same grid name is used in the ETABS grid bubble.
• Grid Points: The start and end points are used to define the general grid line in ETABS.
• Curved Grid: The center point, radius, start angle and aperture are used to define the
circular grid line in ETABS.
Materials
The following material attributes are created in ETABS:
• Material Name: The same name is used in ETABS.
• Material Type: The Revit material type is used to identify the ETABS material type,
namely Concrete, Steel or Other.
• Young’s Modulus: The Young’s modulus values from Revit set the ETABS material
Young’s modulus (E). These three values (for the three different directions) cannot be
zero in ETABS. If the first value is zero, then the default ETABS value is used. If any of the
remaining two are zero, then the first non-zero value is used. For an isotropic material,
the first value is used for all other directions.
• Poisson’s Ratio: Poisson’s Ratio values from Revit set the ETABS material Poisson’s Ratio
(u). These three values (for the three different directions) cannot be zero in ETABS. If the
first value is zero, then the default ETABS value is used. If any of the remaining two are
zero, then the first non-zero value is used. For an isotropic material, the first value is
used for all other directions.
• Shear Modulus: Shear Modulus value from Revit set the ETABS material Shear Modulus
(G). If the Revit material is defined as isotropic, then ETABS calculates this value on the
basis of the Young’s Modulus and the Poisson’s Ratio. In the case of an orthotropic
material, these three values (for the three different directions) cannot be zero in ETABS.
If the first value is zero, then the default ETABS value is used. If any of the remaining two
are zero, then the first non-zero value is used.
• Thermal Expansion Coefficient: The thermal expansion coefficient from Revit sets the
ETABS material thermal expansion coefficient (Alpha). These three values (for the three
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different directions) cannot be zero in ETABS. If the first value is zero, then the default
ETABS value is used. If any of the remaining two values are zero, then the first non-zero
value is used. For an isotropic material, the first value is used for all other directions.
Weight Density and Mass Density: The unit weight value from Revit sets the ETABS
material weight density (w) and mass density (m). In ETABS, the mass density is
calculated by dividing the weight density by the gravitational constant (g). The weight
density cannot be zero in ETABS. If the unit weight is zero in Revit, then the default
ETABS densities are used.
Damping Ratio: This value is not in used in the current version of ETABS.
Bending Reinforcement: The bending reinforcement value from Revit sets the ETABS
material main reinforcement Fy if the type is concrete. If this value is zero in Revit, then
the default ETABS value is used.
Shear Reinforcement: The shear reinforcement value from Revit sets the ETABS material
shear reinforcement Fy if the type is concrete. If this value is zero in Revit, then the
default ETABS value is used.
Resistance Calculation Strength: The resistance calculation strength from Revit sets the
ETABS material f’c factor. If this value is zero in Revit, then the default ETABS value is
used.
Behavior: The Revit behavior tag is used to identify the isotropic or orthotropic materials
in ETABS.
Concrete Compression: The concrete compression value from Revit sets the ETABS
material f’c if the type is concrete.
Lightweight: The Revit lightweight tag is used to identify the lightweight concrete
material in ETABS.
Shear Strength Reduction: This value is not in used in the current version of ETABS.
Yield Stress: The yield stress value from Revit sets the ETABS material yielding stress Fy if
the type is steel. If this value is zero in Revit, then the default ETABS value is used.
Tensile Strength: The tensile stress value from Revit sets the ETABS material ultimate
stress Fu if the type is steel. If this value is zero in Revit, then the default ETABS value is
used.
Steel Reduction Factor: This value is not in used in the current version of ETABS.

Only those materials linked with floors, walls, or frames in the Revit project are imported
into ETABS.
ETABS writes a warning in the .wrn file it writes when a default value is used while importing
materials from the Revit project.
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Structural Columns and Framing
The following Revit column and framing element attributes are imported into ETABS:
• Frame Curves: Straight framing elements are imported as straight ETABS frame objects.
Curved framing elements that are not arc shaped are imported as series of short ETABS
objects based on the lines defining their analytical models. Arc shaped framing elements
are imported as arc shaped ETABS line objects.
• Frame End Points and Curves: For straight column and framing elements and curved
framing elements other than arc shaped, the coordinates of the end points of the lines
defining the analytical model of the element are retrieved and ETABS joint objects with
identical coordinates are created. When the analytical model of an element includes
rigid links, the ETABS joint objects are created at the ends of the rigid links with ETABS
joints offsets created to model the link. For arc shaped framing elements, the
coordinates of the end points of the elements themselves are imported instead of the
end points of their analytical models because these analytical models consist of series of
short straight segments and such a tessellation is not required in ETABS 2013 and later.
Columns are imported with the Local Axis 1 always pointing up, and beams and braces
with their Local Axis 1 always in the first quadrant, which means that the end joints may
have been switched compared to the Revit end points. Multi-story columns and braces
are automatically broken into several single story ETABS frame objects. This is required
for reporting and design.
• Frame Sections: The family type assigned to the Revit element is imported along with the
whole family. ETABS converts the Revit family to an ETABS auto selection list.
• End Releases: End releases defined in the element analytical models are imported into
ETABS. ETABS restricts releases that would cause an analytical instability, such as for
example torsion released at both ends. When that happens, ETABS writes a warning in
the .wrn file it writes. When ETABS joints have been switched compared to Revit end
points, end releases are also switched.
• Insertion Points: In Revit, the beam or brace insertion point is defined by the following
two parameters:
o Z-Direction Justification
o Lateral Justification
ETABS calculates the corresponding insertion point on the basis of these two parameters.
If these parameters are not defined then the default alignment, Top Center, is chosen.
Columns in Revit have no parameters corresponding to the ETABS insertion point and
they are imported with a Middle Center insertion point.
• End Offsets: When the analytical model of an element includes rigid links, these are
imported as end offsets. You can visualize them by looking at the model in extruded view.
In addition, when a beam has its z-Direction Justification parameter set to Other, an
additional vertical offset is created at both ends of the ETABS frame object based on the
value of the z-Direction Offset parameter. Other beam offset parameters such as Start
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Level Offset and End Level Offset are not taken into consideration because, except for arc
shaped members, end joints are located based on the end points of the analytical model
which already reflects the values of these parameters. When ETABS joints have been
switched compared to Revit end points, end offsets are also switched.
Orientation Angles: The ETABS Local Axis 2 Angle of columns is computed based on their
rotation as internally stored in Revit. The ETABS Local Axis 2 Angle of beams and braces is
computed based on the value of their Cross-Section Rotation parameter. When ETABS
joints have been switched compared to Revit end points, rotations are adjusted
accordingly.

Frame Sections
The mapping of Revit frame section attributes depends upon their type.
ETABS first tries to find the name of the section in its database. Most steel sections can be
mapped automatically. If a section is not found in the database, ETABS tries to create these
sections parametrically.
ETABS maps sections through the following steps:
1) ETABS first tries to map Revit family sections to the currently loaded ETABS database by
comparing section names. If it finds a match then that section is mapped. All geometric
cross sectional properties are used from the ETABS section. Blank spaces are always
removed and upper/lower cases dissimilarities are ignored when comparing names.
2) Next, ETABS tries to map Revit family sections to a section in the ETABS section property
files (.XML) by comparing section names. If ETABS finds a section with a matching name,
then that section is used along with all its geometric cross sectional properties. In the
absence of an exact name match, ETABS looks for a close match where the Revit name
contains the ETABS name. The user is given the option to add/remove or change the
search order of the property files during the import into ETABS from the Revit project. In
Figure 1, “UC356x406x287” section is loaded from “BSShapes.XML”.
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Figure 1: Import of sections from section property files (.XML files)

Figure 2: Adding /Removing XML files when importing into ETABS

3) If a Revit family section cannot be mapped to an ETABS section from any of the property
files, then ETABS checks if it is a Revit parametric section. If it is a parametric section,
ETABS creates an equivalent section and names it after the Revit family section.

4) If a Revit family section is not parametrically defined, then a new ETABS section named
after the Revit family section is created with default ETABS section properties. The user
has the option to add a new parametric section as a replacement section or to load a
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new section from any other section property file(.XML) that is not in the properties file
(.XML) list.
5) The user has the option to save a mapping file which can then be reused on subsequent
imports. A sample mapping file is shown in Figure 3.

Figure 3: Section mapping file

6) Some European family names do not map with the ETABS sections in European
properties file (.XML) due to prefix/suffix incompatibility. For Revit families with
“Universal Columns” or “Universal Beams” categories, ETABS changes the suffix to prefix
when importing.
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The parameters list is given for concrete and wood structural families in the following table.
Member Type
CONCRETE
COLUMNS

CONCRETE
FRAMING

Family Name
CONCRETE-RECTANGULARCOLUMN
CONCRETE-ROUND-COLUMN
CONCRETE-SQUARECOLUMN
PRECAST-RECTANGULAR
COLUMN
PRECAST-DOUBLE TEE

PRECAST-INVERTED TEE
PRECAST-L SHAPED BEAM
CONCRETE-RECTANGULAR
BEAM, PRECASTRECTANGULAR BEAM
PRECAST-SINGLE TEE

WOOD
COLUMNS

WOOD
FRAMING

STEEL
FRAMING

DIMENSION LUMBERCOLUMN
GLULAM-SOUTHERN PINECOLUMN
GLULAM-WESTERN SPECIESCOLUMN
PSL-PARALLEL STRAND
LUMBER-COLUMN
TIMBER-COLUMN
DIMENSION LUMBER
GLULAM-SOUTHERN PINE
GLULAM-WESTERN SPECIES
LVL-LAMINATED VENEER
LUMBER
TIMBER
OPEN WEB JOIST
PLYWOOD WEB JOIST
PLATE
ROUND BAR

Table 1: Parameters used in ETABS
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Parameters
B, H
B
B
B, H CHAMFER
WIDTH, TEE WIDTH,
STEM WIDTH, SLAB
DEPTH, DEPTH
H1, H, B, SEAT
H1, H, B, SEAT
B, H

WIDTH, STEM
WIDTH, SLAB DEPTH,
DEPTH
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, H
B, H
B, D
D

In-place family members
Revit in-place family members are not imported into ETABS.
Walls
The following wall attributes are imported into ETABS:
• Points: The coordinate of all points defined in the wall analytical model are retrieved and
ETABS joint objects with identical coordinates are created. Revit walls may be defined as
having more than four corners, but ETABS walls can only have three or four nodes. Revit
walls with more than four outer corners are broken into several four node walls, with a
few three node walls when some of the edges are sloped. Also, multi-story walls are
broken into several single story ETABS walls. This is required for reporting and concrete
reinforcement design.
• Wall Curve: Arc shaped curved walls with horizontal bases and tops are imported as
ETABS curved walls. Straight wall edges are imported as such. Other edges are
tessellated, with the degree of approximation defined internally by Revit, and the wall is
imported as a series of walls. Note that when a Revit wall is arc shaped in plane but its
top is not horizontal, its top curve is not an arc and will be tessellated.
• Wall Openings: Wall openings are imported based on their locations. Opening with more
than four corners are broken into three and four node openings. Multi-story openings
are broken into several single story openings.
• Wall Thickness: A Revit wall has different layers, each having different thickness and
material properties. ETABS only considers the layer with the maximum thickness when
importing the data from Revit.
• Wall Materials: All the materials assigned to the different layers of a Revit wall are
imported into ETABS. However, only one material is assigned to the ETABS wall section
property. Users have the option in ETABS to change the material, if necessary. The
material of the wall layer with the maximum thickness is used.
Slanted or warped walls, with their top not lined up with the base when looked at from
above, are not imported.
Floors
The following floor attributes are imported into ETABS:
• Floor Points: The coordinate of all points defined in the floor analytical model are
retrieved and ETABS joint objects with identical coordinates are created.
• Floor Curves: Floor edges that are arc shaped are imported as arcs in ETABS. Straight
floor edges are imported as such. All other curved floor edges are tessellated, with the
degree of approximation defined internally by Revit. Floors with more than four outer
corners are projected onto a horizontal plane at an elevation matching their average
elevation.
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Number of Layers: In Revit, different layers may be defined within a floor. ETABS reads
the floor layer information and treats the floor as a deck if more than one layer is
present in the floor. Otherwise the floor is treated as a slab.
Layer Thickness: ETABS imports the thickness of each layer. If the floor is a deck, its
section property is defined by the maximum thickness of the layers.
Below is an example of how Revit Deck parameters are mapped to ETABS Deck Section
parameters:
Revit Deck Family
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ETABS Deck Section

In this example, there are two layers in the Revit Deck section:
1) Concrete – Cast-in-Place (Thickness = 5”)
2) Metal – Deck (Thickness = 0 )
Layer 2 stands for a deck profile with the following properties:
•
•
•
•
•

HR
WR
RR
SR
THICKNESS
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Here is the procedure CSiXRevit uses to fill ETABS deck section properties:
• The layer with the maximum thickness is selected and treated it as the overall
thickness of the section. This layer is used to define the material of the ETABS
deck section.
• Slab Depth tc = overall thickness of section – HR
• Deck Depth hr = HR
• Rib Width Top wrt = WR
• Rib Width Bottom wrb = RR
• Rib Spacing Sr = SR
• Composite Deck Studs diameter = RR
• Composite Deck Stud height (hs) = overall thickness of section - THICKNESS
•

•
•

•

Layer Materials: ETABS imports the material of each layer. The material of the thickest
layer is assigned to the Slab or Deck section. A default material is used if no material is
defined in Revit. Users may later change the material of the different layers as required
in ETABS.
Floor Span Directions: The Revit span direction is imported for decks. A default direction
is used if no span direction is defined in Revit.
Floor Openings (Regular or Irregular): Openings defined in Revit by
“Modeling>Opening>Vertical Opening” are imported into ETABS. All curves in such
openings are converted into a number of smaller segments, which gives the suitable
curvature for the area boundary.
Ramps: All inclined slabs with four nodes are imported as ramp objects in ETABS.

Openings
The following openings are imported into ETABS from Revit:
• Horizontal Openings: These are imported as openings in the floors.
• Wall Openings: These are imported as openings in the walls (vertical planes). For details,
please check Openings in Walls.
• Shaft Openings: These are imported as openings in the floors (horizontal planes). For
details, please check Shaft Openings.
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Shafts
In Revit, a shaft opening element is defined as a 3D shaft having upper and lower limits (or
offset elevations from upper and lower story levels). In ETABS the shaft is imported as
horizontal floor openings at all the story levels that lie between the upper and lower limits of
the 3D shaft.
Footings
The following footing properties are imported into ETABS from Revit:
• Points: All the points defining the shape of the footing are imported. In ETABS all
columns that are located in this area are restrained.
• Width, Length and Thickness: For rectangular footings, the width, length and thickness
are imported. In this case, ETABS locates all the columns within the rectangular footing
area and restrains them.
Note: Only rectangular footings are processed.
Point Loads
The following point load attributes are imported into ETABS from Revit:
• Load Case Name: It sets the corresponding load case name in ETABS.
• Location: It is used to define the point of application of the load.
• Fx, Fy, Fz, Mx, My, Mz: All forces and moments applied in the global direction, in Revit,
are transferred in a similar manner into ETABS.
Line Loads
The following line load attributes are imported into ETABS from Revit:
• Load Case Name: It sets the corresponding load case name in ETABS.
• Start and End Point Locations: Used to define the start and end point of the line load.
Line loads carrying the gravitational load and overlapping more than one beam are
distributed to the corresponding beams in ETABS. In the case of a lateral line load, users
must check no line load overlaps more than one beam; otherwise it is not processed in
the ETABS analysis.
• Fx, Fy, Fz, Mx, My, Mz: All forces and moments applied in the global direction, in Revit,
are transferred in a similar manner into ETABS. A Revit line load which includes more
than one of these components is imported as several ETABS line loads because ETABS
line loads are mono-directional.
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Area Loads
The following area load attributes are imported into ETABS from Revit:
• Load Case Name: It sets the corresponding load case name in ETABS.
• Points: Points are used to define the geometry of the loading area. Curved edges that are
arc shaped are imported as arcs. Straight edges are imported as such. Other edges are
tessellated, with the degree of approximation defined internally by Revit.
• LoadX, LoadY, and LoadZ: All loads applied in the global direction in Revit are transferred
in a similar manner into ETABS.
Non-uniform surface loads are not supported in ETABS and not imported.
Load Cases
The following load case attributes are imported into ETABS from Revit:
• Load Case Name: The same name is used for the ETABS load case.
• Load Case Category: It is used to define the load case type in ETABS. The mapping is
shown in the following table:
Revit Load Case
Category
Dead
Live
Wind
Snow
Roof Live
Accidental
Temperature
Seismic

ETABS Load Case Type
Dead
Live
Wind
Snow
Live
Other
Other
Quake

Load Combos
The following load combination attributes are imported into ETABS from Revit:
• Load Combination Name: The same name is used for the ETABS Load Combination
Name.
• Load Cases: The same load cases list is used in ETABS to define the Load Combination.
• Load Case Factor: The same load case factors are used for the corresponding load cases
in the ETABS load combination.
ETABS Auto Select Lists
ETABS automatically creates Auto-select lists based on Revit family types that are loaded in
the current Revit project and being exported into ETABS.
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Exporting from Revit to update an existing ETABS model
The table below provides an overview of the data imported in ETABS when exporting from Revit
to update an existing ETABS model:
Action
Creation of…

Model Element

Supported

Grids
Story Levels
Materials
Frames

Notes

Creates equivalent ETABS materials.
Transfers geometry, offsets, end releases, and
beam and brace alignment points, into ETABS.
Cuts all columns at story levels.

Frame Sections
Steel Sections
Concrete Sections
Walls
Wall Properties

Maps to ETABS database sections.
Creates and maps equivalent ETABS sections.

Wall Openings
Floors
Slabs Properties
Deck Properties
Floor Openings
Footings

Creates fixed joint restraints in ETABS wherever a
footing occurs in Revit.

Joint Loads
Frame Loads
Shell Loads
Load Cases
Load Combos
Update of…
Grids
Story Levels
Materials
Frames
Frame Sections

X
X
X
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Steel Sections
Concrete Sections
Walls
Wall Properties
Wall Openings

X
X
Walls with changing number of sides are
replaced.

X
X

Wall openings with changing number of sides are
replaced.

Floors
Slabs Properties
Deck Properties
Floor Openings

X
X
X

Point Loads
Line Loads
Area Loads
Load Cases
Load Combos

X
X
X
X

Floor openings with changing number of sides
are replaced.

Deletion of…
Grids
Story Levels
Frames
Walls
Wall Openings
Floors
Floor Openings
Footings
Point Loads
Line Loads
Area Loads
Load Cases
Load Combos

IMPORTANT NOTE: Deletion of objects when updating a model only works if you are sending
the ENTIRE model. If the “selection only” update feature is used, deletion of items is not
supported.
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Importing from ETABS to create a new Revit Project
The table below provides an overview of the data imported in Revit when creating a new Revit
project:
Action
Creation of…

Model Element

Supported

Grids
Story Levels
Materials

Notes

Imports Concrete and Steel materials into Revit
from ETABS. Limitation is the Revit project
should have one default concrete and one
default steel material for duplication, otherwise
the material will be created in Revit but its
parameters will not be updated, and the
properties of the new materials are identical to
those of the template materials.
Imports steel columns based on splice locations
in ETABS.
Column alignment points are not exported to
Revit because the concept is not supported in
Revit.

Frames
Frame Sections

Steel Sections
Concrete Sections

Creates and maps equivalent Revit sections.
See mapping below.
Slanted walls not imported.

Walls
Wall Properties
Wall Openings
Floors
Slabs Properties
Deck Properties
Footings
Load Cases
Joint Loads
Frame object Loads

Creates equivalent Revit point line loads and
trapezoidal line loads.
Creates equivalent Revit area loads.

Shell Member Loads
Load Combos
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Mapping of ETABS section types to Revit families:
Columns
ETABS
Rectangular
Square
Circular

Revit Family
Concrete-Rectangular-Column.rfa
Concrete-Square-Column.rfa
Concrete-Round-Column.rfa

Beams and Braces
ETABS
Rectangular
L
T
Steel Plate
Steel Rod

Revit Family
Concrete-Rectangular Beam.rfa
Precast-L Shaped Beam.rfa
Precast-Single Tee.rfa
Plate.rfa
Round Bar.rfa
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Importing from ETABS to Update an Existing Revit Project
The table below provides an overview of the data imported in Revit when updating an existing
Revit project:
Action
Creation of…

Model Element

Supported

Grids
Story Levels
Materials
Frames
Frame Sections
Steel Sections
Concrete Sections

Notes

Creates and maps equivalent Revit sections.
See mapping at end of previous section.

Walls
Wall Properties
Wall Openings
Floors
Slabs Properties
Deck Properties
Floor Openings
Footings
Load Cases
Joint Loads
Line Loads
Area Loads
Load Combos
Update of…
Grids
Story Levels
Materials
Frames

Updates changes to column locations only for
columns not meshed in ETABS and with a 1:1
correspondence between Revit and ETABS. You
can choose between leaving columns meshed in
ETABS in their original Revit locations or replacing
them with the ETABS meshed columns.

Frame Sections
Steel Sections
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Concrete Sections

Updates Beam, Column and Brace section
assignments; however section parameters
themselves do not update. If you would like to
bring in the changes to the parameters from
ETABS, create a new section with the desired
parameters in ETABS and assign the new section
to the frame.
Updates changes in wall location only for walls
not meshed in ETABS and with a 1:1
correspondence between Revit and ETABS. You
can choose between leaving walls meshed in
ETABS in their original Revit locations or replacing
them with the ETABS meshed walls.
Updates wall type assignments; however wall
types themselves do not update. If a wall section
is changed in ETABS, it is imported under a new
name in Revit.
Non-rectangular wall openings are not updated.
Replaces floors which moved, were not meshed
when brought in from ETABS, and with a 1:1
correspondence between Revit and ETABS. You
can choose between leaving floors meshed in
ETABS in their original Revit locations or replacing
them with the ETABS meshed floors.

Walls

Wall Properties

Wall Openings
Floors

Slabs Properties

Updates floor type assignments; however floor
types themselves do not update. If a floor section
is changed in ETABS, it is imported under a new
name in Revit.
Floor openings moved in ETABS are replaced.

Deck Properties
Floor Openings
Load Cases
Point Loads
Line Loads
Area Loads
Load Combos

Area loads moved in ETABS are replaced.

Deletion of…
Grids
Story Levels
Materials
Frames
Walls
Wall Openings
Floors

Non-rectangular wall openings are not deleted.
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Floor Openings

Floor openings imported as a floor shaft and
deleted in ETABS are not deleted.

Load Cases
Point Loads
Line Loads
Area Loads
Load Combos

IMPORTANT NOTE: Deletion of objects when updating a model only works if you are sending
the ENTIRE model. If the “selection only” update feature is used, items are not deleted.
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Procedures
Exporting from Revit to Create/Update a New/Existing ETABS Model
IMPORTANT NOTE: CSiXRevit only exports the analytical models of Revit elements. All the
analytical models of all Revit elements must be correctly connected to each other to ensure the
stability of the ETABS model generated.

Revit Model View
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Revit Analytical Model View
The following steps describe how to send a Revit analytical model to ETABS:
1. To create a new ETABS model, from the Revit menu select, Tools>External
Tools>Export to Create New ETABS SAP2000 or SAFE Model. To update an
existing ETABS model, from the Revit menu select, Tools>External Tools>Export
to Update Existing ETABS or SAFE Model.
2. CSiXRevit counts the elements in the Revit project and displays the Export to
Create New ETABS SAP2000 or SAFE Model form, or Export to Update Existing
ETABS or SAFE Model form as may be the case:
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Select the categories of Revit elements to export to ETABS. If you have selected
some elements prior to starting the command and wish to only export those
elements, check the corresponding box at the bottom of the form.
Once you have made your selections, click OK. The Exporting to Create New
ETABS SAP2000 or SAFE Model or Exporting to Update Existing ETABS or SAFE
model information message box is shown and displays the progress of the export:

30

3. Once the process has run its course, click OK. You are now asked to select a
destination folder and filename. The file will be given the extension .EXR.
4. Start ETABS if it is not already running.
5. To create a new ETABS model from your Revit project, you should not have any
model open, not even an ETABS blank model (an ETABS blank model actually
includes four story levels). By default ETABS creates a new model based on your
.EXR file. To update an existing ETABS model, open it.
6. From the menu, select File>Import>Revit Structure .exr file, and then select the
.EXR file to import. If you are creating a new model, this command is available
from the ETABS Start Page.
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7. The Revit Data Overview/Controls form is displayed:

The top section of this form provides access to more forms which let you specify
how Revit levels, materials and families are imported in ETABS.
Any material property with a zero value, any unrecognized section, any section
with a default material displays a warning. If a material property was not defined,
or a material was not assigned in Revit, you can address the issue before the
ETABS model is created. These issues can be addressed by clicking the
corresponding Edit button.
The bottom section of this form displays general controls that ETABS uses when
importing the Revit project. The units selected here are used as the default units
of the ETABS model. The length tolerance is the tolerance ETABS uses to align
close X, Y, Z coordinates and to create connectivity when creating the finite
element model for analysis. The Minimum Curve Length and Angle let you control
how a curve is divided into straight line segments. When you check the Align
close X, Y or Z Coordinates, ETABS may make small adjustments to the original
coordinates in the .EXR file. Adjustments are then made to the coordinates of
grid lines, frame objects, and edges of shell objects that are parallel or almost
parallel to the horizontal plane X or Y axis in the EXR file. These adjustments are
two-fold: All imported such items are made actually parallel to the X or Y axis as
applicable; and all such items that are almost aligned with each other are
actually aligned.
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To review the various story levels imported from Revit click the Edit button. The
ETABS Story Data form is displayed, letting you change story heights and other
story parameters, and add or delete story levels.

8. To review the Revit material properties imported, select the Edit button next to
“Total Materials”. The Material Mapping form is displayed:
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In this model four materials are imported. Any new ETABS material is created
with the same name as the Revit material name. To map the Revit Material to a
material other than the new ETABS material created, click on the ETABS material
name. A combo box will be displayed with all of the existing ETABS materials
currently in the ETABS model. To create a new material property to map your
Revit material to, click Add. The ETABS Add Material form is then displayed. To
see the properties of any imported material, select the material and click Edit.
The ETABS Material Property Data form is then displayed:

To check the original properties of the material in Revit, click “Revit Data...” The
Revit Material Property Data form is displayed:
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9. To see the Revit Frame Sections imported, select the Edit button next to “Total
Frame Sections”. The Frame Section Mapping form is displayed:

The first three columns display the original Revit family type, original family
name, and the material assigned to any section imported from Revit. The fourth
column is the ETABS section the Revit section is mapped to. The final column
describes how the section is mapped or created.
Only the ETABS Section Name column is editable. Clicking any row in the column
displays a combo box that includes all section properties currently loaded in the
current ETABS model. To add a section to the list, click the Add button the right
side.
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When ETABS imports the Revit data, it initially tries to match Revit section names
to ETABS section names. It first searches through the loaded ETABS database
sections. If not matched, it then searches all the ETABS section property files
(.XML). It will map the section to the first section name that matches. To specify
which files are searched, click the .XML Files button on the right side. The XML
Property Files form is displayed:

All the XML property files present in the ETABS installation directory are selected
by default. A file can be added or removed from the ETABS search by checking or
unchecking its checkbox in the list. To add a new file, click on the Add File button.
To change the order in which ETABS searches the files, move their names up and
down in the list using the arrow key buttons on the right side.
If ETABS cannot create a section mapping by name, it tries to create the section
parametrically. For most steel sections ETABS is able to find a match. For
concrete sections, ETABS will create the sections parametrically. To see how Revit
sections properties are mapped, see the section under “Supported Workflows”
called “Exporting from Revit to create a new ETABS model”.
Similar to the Material Mapping, details about the Frame Section Mapping can be
edited by selecting the row, and clicking the Edit button.
To save the mapping created, the mapping file can be exported by clicking the
Export Mapping File button.
Likewise, to import a previously created mapping file, click the Import Mapping
File button.
10. To see the Revit floor sections imported, select the Edit button next to “Total
Floor Sections”. The Floor Section Mapping form is displayed:
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Again, you can specify the ETABS floor section the Revit floor type gets mapped
to. By default an equivalent ETABS floor section is created and mapped. To create
a new deck or slab section, use the buttons on the right side. After adding the
deck or slab, the new ETABS floor section will show up in the drop down list.
To review the details of an ETABS section, click on the row and then click the
Edit… button. The ETABS Slab Property Data or Deck Properties Data form, as
applicable, is displayed:
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11. To see the Revit wall sections imported, select the Edit button next to “Total Wall
Sections”. The Wall Section Mapping form is displayed:

Again, you can specify the ETABS wall section the Revit wall type gets mapped to.
By default an equivalent ETABS wall section is created and mapped. To create a
new wall section use the Add buttons on the right side. After adding the wall, the
new ETABS wall section shows up in the drop down list.
12. Once you are satisfied with the mapping of materials and sections, in the Revit
Data Overview/Controls form select OK. The ETABS model is created.
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Exporting from ETABS to Create/Update a New/Existing Revit Project
The following steps describe how to export your ETABS analytical model to create or update a
Revit project:
1. Once you have edited, analyzed and designed your structure in ETABS, save the
ETABS file by selecting the File>Save.
2. In ETABS, select File>Export>Revit Structure .exr File and specify a destination
folder and filename in the Export ETABS-Revit Exchange File form which is
displayed.
3. If you have selected objects in the model, and would like to export only those,
select the appropriate box:

4. Start Revit if it is not already running.
5. To create a new Revit project from your ETABS model, open a Revit template that
you would like to import your ETABS model into. It isn’t required, but the import
will come in faster and will be more predictable if you load all the beam, column,
brace, deck, slab and wall families you would like ETABS sections to map to prior
to importing. From the menu select, Tools>External Tools>Import to Create New
Revit Project from ETABS, SAP2000 or SAFE. Select the .exr file you would like to
import. CSiXRevit will try to load any required families that are not already
loaded.
To update an existing Revit project, first open it. Again, if you have new sections
you defined in ETABS, the import will come in faster and will be more predictable
if you load all the beam, column, brace, deck, slab and wall families you would
like ETABS sections to map to prior to importing. From the Revit menu select,
Tools>External Tools>Import to Update Existing Revit Project from ETABS. Select
the .exr file to import.
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6. Whether creating a new Revit project or updating an existing Revit project, after
selecting the .EXR file, the following form is displayed:

On the left side, you can control the types of ETABS objects to import into the
Revit project and the mapping of ETABS sections to Revit types.
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Clicking the Frame Sections button under “Mapping Options” displays the Frame
Section Mapping form:

Changes to the mapping of ETABS sections to Revit sections can be made here. All
Revit column beam and brace families and family types currently loaded in the
project are displayed in the drop down lists.
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Clicking the Floor Sections button displays the Floor Section Mapping form:

Changes to the mapping of ETABS floor sections to Revit sections can be made
here. All Revit floor families currently loaded are displayed in the drop down lists.
Clicking the Wall Sections button displays the Wall Section Mapping form:

Changes to the mapping of ETABS wall sections to Revit sections can be made
here. All Revit wall families currently loaded are displayed in the drop down lists.
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If you are updating a Revit project from an ETABS model, you have the choice to
only update locations and releases, only update designs and load magnitudes, or
update both:

Also, when updating a Revit project from an ETABS model, there can be instances
in which the 1:1 mapping of Revit elements to ETABS objects is lost because
objects were meshed in ETABS. If this is the case, you have two options:
1. Delete the existing Revit elements, and let CSiXRevit create new elements
corresponding to the objects that are meshed in ETABS.
2. Keep the existing elements as they are and use object mapping to control
the assignment of section properties during the import.
In the case of option #2, there can be situations in which the user has to make
some decisions. For example, if a column in Revit runs from the ground floor to
the top floor as a single element, when imported into ETABS, the column is cut at
every floor level. When it is designed, different sections might be assigned to
each segment of the column. When the column (that is now meshed in ETABS) is
imported back into Revit, you have the option to 1) delete the original column in
Revit and have CSiXRevit create a column with the varying sections or to 2) select
one of the frame sections for the entire length of that column. To do this, select
the corresponding checkbox and click the Objects button under Mapping
Options. The Object Mapping form is displayed:
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In this case, Column ID (139774) spans three floors in Revit but was meshed into
three pieces in ETABS. When coming back into Revit, you can choose which
section to assign to the entire length of the column. The same can be done with
meshed beams, braces, floors and walls.
Once you are satisfied with the object mappings, select OK and the ETABS model
will be imported.
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Reviewing the Log File (.log)
Every time a model is sent from Revit to ETABS or from ETABS to Revit, a file with
the extension .EXRlog is created if it does not exist, or appended if it already
exists. This file lists the project or model name, the workflow operation, and the
time and date. It also lists any errors or omissions encountered in generating or
importing the .EXR file, and therefore, should be checked every time data is
transferred. The .EXRlog file also lists the build numbers for CSiXRevit and Revit.
The two should be identical to ensure no misinterpretation of data occurred. The
first few lines of the .log file have the following format (the actual data may be
different):
CSixRevit Revit API Version = 2019.0
CSixRevit Build = 20180216_1515(x64)
Current Revit Version = 2019.0
Current Revit Build = 20180216_1515 (x64)

The “Build =” numbers should be the same – having the same Version numbers
but different Build numbers does not guarantee data consistency.
Finally, in the case of an incremental import, the changes made to the Revit
project are listed.
Added Area Load for the following elements:
262405 to replace 262161
262422 to replace 262188
262439 to replace 262205
262456 to replace 262222
262473 to replace 262239
262490 to replace 262256
Added Floor for the following elements:
262383 to replace 262086
262393 to replace 262117
262401 to replace 262125
Changed Beam camber for the following elements:
262053 to C=1.75"
262056 to C=1.75"
262059 to C=1.75"
262062 to C=1.75"
262065 to C=1.75"
262068 to C=1.75"
262071 to C=1.75"
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262074 to C=1.75"
262077 to C=1.75"
Changed Beam end reactions for the following elements:
262053
262056
262059
262062
262065
262068
262071
262074
262077
Changed Beam shear studs for the following elements:
262053 to (20)
262056 to (20)
262059 to (20)
262062 to (20)
262065 to (20)
262068 to (20)
262071 to (20)
262074 to (20)
262077 to (20)
Moved Structural Member for the following elements:
261993 by 10.00 ft, 0.00ft
261996 by 10.00 ft, 0.00ft
262000 by 10.00 ft, 0.00ft
262003 by 10.00 ft, 0.00ft
262005 by 10.00 ft, 0.00ft
262008 by 10.00 ft, 0.00ft
262012 by 10.00 ft, 0.00ft
262015 by 10.00 ft, 0.00ft
262017 by 10.00 ft, 0.00ft
262020 by 10.00 ft, 0.00ft

Each Revit element is identified by its “Revit ID”. You can view the element IDs by selecting
Manage->Select by ID in the Revit ribbon, typing an ID, and clicking the Show button:

Revit will find a view that contains the element, switch to that view, and highlight the element.
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Known Limitations with CSiXRevit and ETABS
1. If your version of Windows includes strict UAC (User Account Control), you need to
run ETABS.exe and Revit.exe with the option “Run as Administrator”. If Revit is not
run with administrator privileges, there is a risk CSiXRevit will not be able to open the
.EXRlog file. In this case, CSiXRevit will not write any warnings to the log file but all
warning messages will be displayed on the screen.
2. Revit floors that are grouped together may be treated as openings when importing
into ETABS.
3. Import of European and Chinese steel sections from Revit to ETABS is possible if their
corresponding .XML files are present in the ETABS folder.
4. Materials imported into Revit from ETABS may not always be properly assigned or
the property values may not always be properly transferred. For this reason, material
assignments and material property values should always be carefully checked in Revit
after importing from ETABS.
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Revit and SAP2000 Data Exchange
Data exchange between CSiXRevit and SAP2000 supports two different workflows:
1) Exporting from Revit to create new SAP2000 model.
2) Exporting from Revit to update an existing SAP2000 model. SAP2000 v17.2.0 or
later is required.
3) Importing from SAP2000 to create a new Revit project.
4) Importing from SAP2000 to update an existing Revit project. In this case, you may
choose to update locations, designs, or both. SAP2000 v17.2.0 or later is required.

Supported Workflows
Exporting from Revit to create a new SAP2000 Model
The table below provides an overview of the data transferred from Revit to SAP2000:
Action
Creation of…

Project Element

Supported

Grid Lines
Materials
Steel
Concrete
Aluminum
Generic
Other
Wood
Frames

Notes
Does not transfer.

Does not transfer reinforcement properties.
Imports as isotropic “Other” SAP2000
material type.

Transfers geometry, beam and brace
alignment points, and end releases into
SAP2000. Ignores end offsets. Imports curved
Revit framing as a series of short straight
SAP2000 frame objects.

Frame Sections
Rolled Steel Sections

Loads equivalent SAP2000 section profiles
from the SAP2000 .PRO files specified during
import of the .EXR file into SAP2000.
Imports with “None” properties.
Creates and maps equivalent SAP2000
sections.
Imports walls as SAP000 area objects with
wall openings imported as separate area
objects with “None” properties. Imports

Bar Joists
Concrete Sections
Walls
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curved Revit walls as a series of short planar
SAP2000 area objects. Warped walls with
more than four sides not imported.
Creates and maps equivalent SAP2000 thick
shell sections.
Imports floors as SAP000 area objects with
floor openings imported as separate area
objects with “None” properties.
Creates and maps equivalent SAP2000 thick
shell sections.
Creates and maps equivalent SAP2000 thick
shell sections with directional stiffness
modifiers.
Does not transfer.

Wall Properties
Floors

Slabs Properties
Slab on Deck
Properties
Footings
Point Loads

Creates SAP2000 joints if the load does not
coincide with a previously created joint and
does not line up with any frame objects. This
will cause model instability that needs to be
addressed.
Creates SAP2000 frame objects with “None”
properties if the load does not overlap any
other frame object. If the load also does not
line up with any imported floor or wall, it will
cause model instability that needs to be
addressed.
Does not transfer.

Line Loads

Area Loads
Load Cases
Load Combinations

Grid Lines
Revit grid lines are not imported in the current version of SAP2000.
Materials
All Revit materials are imported into SAP2000 as isotropic materials. The following Revit
material attributes are imported into SAP2000:
• Material Name: The same name is used in SAP2000.
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•
•
•
•

•
•

•
•
•
•
•

Material Class: Concrete and steel set to equivalent SAP2000 material types. Generic,
aluminum, and wood material types set as “Other” SAP2000 material type.
Young’s Modulus: The first of Revit’s three Young’s modulus values (one for each
direction) sets the SAP2000 material Young’s modulus (E) value. If this value is zero, the
default SAP2000 value is used.
Poisson’s Ratio: The first of Revit’s three Poisson’s Ratio values (one for each direction)
sets the SAP2000 material Poisson’s Ratio (U) value. If this value is zero, the default
SAP2000 value is used.
Shear Modulus: The first of Revit’s three Shear Modulus values (one for each direction) is
compared to the value of the material Shear Modulus (G) computed by SAP2000. If the
two differ by more than one percent in SAP2000, a warning is reported in the log file.
Thermal Expansion Coefficient: The first of Revit’s three thermal expansion coefficients
(one for each direction) sets the SAP2000 material thermal expansion coefficient (Alpha).
If this coefficient is zero, the default SAP2000 value is used.
Unit weight: The Revit unit weight sets both the SAP2000 material weight density (w)
and mass density (m). In SAP2000 the mass density is calculated by dividing the weight
density by the gravitational constant (g). If the unit weight is zero, the default SAP2000
value is used.
Behavior: Revit uses this tag to distinguish between isotropic and orthotropic materials.
All Revit materials are imported as isotropic materials in SAP2000. Any orthotropic
material generates a warning in the log file.
Concrete Compression: In the case of a concrete material, the Revit concrete
compression sets the SAP2000 concrete compressive strength f’c.
Lightweight: The value of this tag is used to identify a concrete material as lightweight
concrete in SAP2000.
Yield Stress: In the case of a steel material, this value sets the SAP2000 minimum yield
stress Fy. If the yield stress is zero, the default SAP2000 value is used.
Tensile Strength: In the case of a steel material, this value sets the SAP2000 minimum
tensile stress Fu. If the tensile stress is zero, the default SAP2000 value is used.

The following Revit material attributes are not imported in the current version of SAP2000:
• Damping Ratio
• Bending Reinforcement
• Shear Reinforcement
• Resistance Calculation Strength
• Shear Strength Reduction
• Steel Reduction Factor
Only those materials associated with walls, framing, or floors in the Revit project are
imported into SAP2000.
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Frames
The following Revit frame member attributes are imported into SAP2000:
• Analytical Model End Points: The point coordinates are used to locate matching joints
already created, and when none can be found, create new joints. When importing end
points, SAP2000 views two points as coincident if none of their coordinates differ by
more than 1/100th of a foot. This level of precision corresponds to the level of precision
in the Revit database.
• Frame Curves: SAP2000 does not support curved frame objects and any curved Revit
member is imported as a series of short straight SAP2000 frame objects. Revit controls
how the curve is broken into segments.
• Family Type: See Frame Sections below.
• Frame Releases: All frame releases defined in Revit are imported into SAP2000 as line
object releases. Releases that cause model instability are restrained and a warning is
reported in the log file.
• Beam Insertion Point: In Revit, a beam insertion point is defined by the following two
parameters:
o Z-Direction Justification
o Lateral Justification
SAP2000 calculates the corresponding alignment point on the basis of these two
parameters. If these parameters are not defined, then the default alignment point
(middle center) is chosen.
• Column Orientation and Beam and Brace Cross-Section Rotation: This angle measures the
rotation of the member around its longitudinal axis in Revit and sets the value of the
“Rotation about 1” angle in elements imported into SAP2000. The two angles are
measured identically in both programs except they differ by 90⁰ in the case of columns.
The following Revit frame member attributes are not imported into the current version of
SAP2000:
• Column Beam and Brace Vertical End Offsets: Revit column beams and brace vertical end
offsets are not imported into SAP2000 because Revit element end points are retrieved
from their analytical models.
• Column Insertion Point: The alignment point of imported columns is always middle
center.
• Rigid Links
Frame Sections
Frame member sections are defined in Revit by their assigned family type.
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When reading an .exr file, SAP2000 attempts to match each Revit frame member family type
to an identically named section profile defined in the AISC13.pro file (or AISC13M.pro
depending on the display unit system in use when importing begins).
In the absence of such a match, SAP2000 checks if the type is from one of the parametric
families (Table 2) for which it knows how to generate sections for.
Any frame member type not matched becomes an unrecognized type for which SAP2000
requires additional user input.
This additional input is entered in the Import Revit .exr file form displayed when an import
into SAP2000 begins. Here all unrecognized types are listed in a table, allowing them to be
manually matched to predefined SAP2000 section profile names or, as a last resort, to the
SAP2000 “None” property.

Here additional section properties databases (.PRO files) can be loaded. When adding a
properties file (.PRO), the unrecognized Revit types are checked against the section profile
names in this file. This may resolve most of the unrecognized types if the correct properties
file (.PRO) is chosen.
SAP2000 saves the properties files (.PRO) manually loaded and the manual assignments
made here in a file with an .EXRMap extension. When importing into SAP2000 the same
Revit project again, SAP2000 will automatically restore these choices.
When loading an .exr file, SAP2000 keeps track of which materials are used in conjunction
with which section profiles. When a section profile is always used with the same material,
the corresponding section property is named after the profile. If a section profile is used

52

with a number of different materials, the various corresponding section properties will have
compound names consisting of the profile name with the relevant material name appended.
The parameters for concrete and wood structural families are listed in the table below:
Member Type
CONCRETE
COLUMNS

CONCRETE
FRAMING

Family Name
CONCRETE-RECTANGULARCOLUMN
CONCRETE-ROUND-COLUMN
CONCRETE-SQUARECOLUMN
PRECAST-RECTANGULAR
COLUMN
PRECAST-DOUBLE TEE

PRECAST-INVERTED TEE
PRECAST-L SHAPED BEAM
PRECAST-RECTANGULAR
BEAM
PRECAST-SINGLE TEE

WOOD
COLUMNS

WOOD
FRAMING

DIMENSION LUMBERCOLUMN
GLULAM-SOUTHERN PINECOLUMN
GLULAM-WESTERN SPECIESCOLUMN
PSL-PARALLEL STRAND
LUMBER-COLUMN
TIMBER-COLUMN
DIMENSION LUMBER
GLULAM-SOUTHERN PINE
GLULAM-WESTERN SPECIES
LVL-LAMINATED VENEER
LUMBER
TIMBER
OPEN WEB JOIST
PLYWOOD WEB JOIST

Table 2: Parameters used in SAP2000
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Parameters
B, H
B
B
B, H CHAMFER
WIDTH, TEE WIDTH,
STEM WIDTH, SLAB
DEPTH, DEPTH
H1, H, B, SEAT
H1, H, B, SEAT
B, H
WIDTH, STEM
WIDTH, SLAB DEPTH,
DEPTH
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, D, SY, SX, IY, IX, A
B, H
B, H

In-place Family Members
Revit in-place family members are not imported into the current version of SAP2000.
Walls
Revit walls are imported into SAP2000 as area objects. The following Revit wall attributes
are imported into SAP2000:
• Analytical Model End Points: The point coordinates are used to locate matching joints
already created, and when none are found, create new joints.
• Wall Curves: Curved vertical Revit walls are imported as a series of short planar SAP2000
area objects. Revit controls how the curve is broken into segments.
• Wall Openings (Regular rectangular shape): This refers to wall openings drawn with the
Revit selection Modeling>Opening>Wall Opening. These openings are imported into
SAP2000 as area objects, with “None” properties, that overlap the area object generated
for the wall.
• Wall Thickness and Material: Revit walls may consist of different layers with different
thickness and materials. The thickness and material type of the layer with the maximum
thickness are used to find or create an appropriate SAP2000 thick shell property. Wall
section properties are named after the Revit wall types. The suffix “-WALL” is appended
to this name if the name is also used for a floor type.
Warped walls with more than four sides not imported.
Floors
Revit floors are imported into SAP2000 as area objects. The following Revit floor attributes
are imported into SAP2000:
• Analytical Model End Points: The point coordinates are used to locate matching joints
already created, and when none can be found, create new joints.
• Floor Curves: SAP2000 does not support curved edges in area objects. All curves in Revit
floors are approximated as a series of straight segments. Revit controls how the curve is
segmented.
• Floor Thickness and Material: Revit floors may consist of different layers. If there is only
one layer, its thickness and material are used to define an equivalent SAP2000 thick shell
property. If there is more than one layer, and one of the layers corresponds to a Revit
deck profile and at least one other is a concrete layer, SAP2000 creates a concrete thick
shell property. Its thickness is equal to the total thickness of all the concrete layers and
the membrane and bending stiffness modifiers assigned will account for the presence of
deck ribs. Floor section properties are named after the Revit floor types.
• Floor Span Direction: Sets the SAP2000 area object local axes.
• Inclined Slabs: Also imported into SAP2000 as area objects.
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Openings
Revit openings are imported into SAP2000 as area objects with “None” properties. This
includes:
• Floor Openings
• Wall Openings
• Shaft Openings: These are imported as SAP2000 area objects located at the base of
the shaft with “None” properties.
Footings
Revit footings are not imported in the current version of SAP2000.
Point Loads
The following Revit point load attributes are imported into SAP2000:
• Load Case Name: Sets the load pattern name in SAP2000.
• Location: The point coordinates are used to locate a matching joint already created.
SAP2000 views a joints and a point load as coincident if none of their coordinates differ
by more than 1/20th of a foot. This level of precision corresponds to the level of precision
in the Revit database. When no coincident joint is found, SAP2000 looks for an
underlying frame object. If no suitable frame object is found, SAP2000 creates a new
joint. This new joint creates model instability that needs to be addressed.
• Fx, Fy, Fz, Mx, My, Mz: All forces and moments are defined in the global coordinates
system in Revit and defined in SAP2000 in a similar manner.
Line Loads
The following Revit line load attributes are imported into SAP2000:
• Load Case Name: Sets the corresponding load case name in SAP2000.
• Start and End Point Locations: These define the start and end points of the line load. A
line load overlapping more than one frame object is distributed on the corresponding
frame objects. If all or part of the load cannot be assigned to frame objects, new frame
objects with “None” properties are created. This will cause model instability if the load
does not also line up with any imported floor or wall.
• Fx, Fy, Fz, Mx, My, Mz: All forces and moments are defined in the global coordinates
system in Revit and defined in SAP2000 in a similar manner.
Area Loads
Revit area loads are not imported in the current version of SAP2000.
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Load Cases
Revit load cases are imported into SAP2000 as both load patterns and load cases. One load
pattern and one load case are both created in SAP2000 for each Revit load case. The
following Revit load case attributes are imported into SAP2000:
• Load Case Name: Sets the corresponding load case name in SAP2000.
• Load Case Category: This defines the load case type in SAP2000. The mapping is shown in
the following table:
Revit Load Case
Category
Dead
Live
Wind
Snow
Roof Live
Accidental
Temperature
Seismic

SAP2000 Load Case Type
Dead
Live
Wind
Snow
Live
Other
Temperature
Quake

Load Combinations
The following Revit load combination attributes are imported into SAP2000:
• Load Combination Name: The same name is used in SAP200.
• Load Cases: The same load case list is used in SAP2000.
• Load Case Factors: The same load case factors are used in SAP2000.
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Importing from SAP2000 to create a new Revit Project
The table below provides an overview of the data transferred from SAP2000 to Revit:
Action
Creation of…

Model Element

Supported

Grid Lines
Joints
Materials (isotropic)

Notes
Does not transfer.
Does not transfer, but force joint loads transfer.
Creates material. Limitation is the Revit project
should have one default concrete and one
default steel material for duplication, otherwise
the material will be created in Revit but its
parameters will not be updated, and the
property of the new materials are identical to
those of the template materials.
Does not transfer.

Materials
(orthotropic)
Frames
Vertical Frames

Creates as columns in Revit. Alignment point,
end length offsets and joint offsets do not
transfer.
Creates as beams in Revit. End length offsets
and joint offsets do not transfer.
Creates as braces in Revit. Alignment point, end
length offsets and joint offsets do not transfer.
Imports as columns, beams, or braces based on
their alignment.

Horizontal Frames
Other Frames
Cables
Frame Sections
“None”
Tapered Sections
Steel Sections

Does not transfer frame object.
Does not transfer frame object.
Maps to Revit family types with matching
names. If not loaded, family type is located and
if found, loaded.
Maps to Revit family types with matching
names. If not loaded, family type is located and
if found, loaded.
Creates and maps equivalent Revit sections.
Does not transfer.

Joists

Concrete Sections
SAP2000 Auto
Select Lists
Shells
Vertical Shells

Imports as walls in Revit.
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Horizontal Shells
Shells in other
planes
Non-planar shells
Shell Properties
“None”
Membrane
Plate
Shell
Layered
Planes
Vertical Planes
Horizontal Planes
Other Planes

Imports as floors in Revit.
Imports in Revit as floors with a slope. Slope
value may require user adjustment.
Does not transfer.
Does not transfer the shell.
Does not transfer stiffness modifiers.

Does not transfer.
Imports as walls in Revit.
Imports as floors in Revit.
Imports in Revit as floors with a slope. Slope
value may require user adjustment.
Does not transfer.
Does not transfer.
Does not transfer.
Does not transfer.

ASolids
Solids
Link/Support
Tendons
Joint Loads
Force

Loads defined in coordinate systems other than
local or global do not transfer.
Does not transfer.

Displacement
Frame Loads
Concentrated
Distributed
Temperature
Strain
Target Force
Internal Force
Shell and Plane
Loads
Uniform
Uniform to Frame
Surface Pressure
Pore Pressure
Temperature
Strain
Load Patterns

Loads defined in coordinate systems other than
local or global do not transfer.
Does not transfer.
Does not transfer.

Loads defined in coordinate systems, other than
local or global do not transfer.
Does not transfer.

Imports as Revit load cases, unless their type
does not correspond to a predefined Revit load
case category.
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Load Cases
Static Linear

Imports into Revit only if all static linear load
cases each refer to a single load pattern. Load
patterns not imported into Revit are not
included in the list of Revit load cases.
Does not transfer.

Other than Static
Linear
Load Combinations

Imports as Revit load combination only if it
refers to more than one load pattern. Load
patterns not imported into Revit are not
included in the list of Revit load cases.

Grid Lines
SAP2000 grid lines are not imported into Revit.
Joints
While model geometry is imported into Revit, SAP2000 joints themselves are not imported.
This restriction includes supports.
Materials
CSiXRevit creates Revit materials with the same names as the SAP2000 materials if they are
not already in the project template:
• Material Name: The same name is used in Revit.
• Material Type: Concrete and steel set to equivalent Revit material classes. Aluminum,
Cold-formed steel and Other set to Revit Generic material class.
• Concrete Compressive Strength: In the case of a concrete material, CSiXRevit attempts to
create a new concrete material which duplicates a Revit concrete material with the same
concrete compressive strength if it can find one in the project template. If not, a new
concrete material is created but its concrete compressive strength differs from the
original SAP2000 value.
• Lightweight Concrete: In the case of a concrete material, sets the corresponding Revit
attribute.
• Minimum Yield Stress: In the case of a steel material, CSiXRevit attempts to create a new
steel material which duplicates a Revit steel material with the same minimum yield
stress if it can find one in the project template. If not, a new steel material is created but
its minimal yield stress differs from the original SAP2000 value.
Only materials associated with exported SAP2000 frame, cable, and area objects are imported
into the new Revit project.
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Frame objects
SAP2000 frame objects are imported into Revit as columns, beams, or braces depending on
whether they are vertical, horizontal, or inclined. Frame object with “None” properties, nonprismatic properties, or a material that cannot itself be exported are not imported into
Revit. The following SAP2000 frame member attributes are imported into Revit:
• Name: The SAP2000 name is imported into Revit as a shared parameter.
• Start and End Joints: The coordinates of their start and end joints set the end points of
the Analytical Models of the new Revit columns, beams, or braces.
• Properties: The name of the SAP2000 properties is exported. When importing frame
objects from an .exr file into Revit, CSiXRevit always attempts to locate and load a Revit
family type with the same name as the SAP2000 properties name. Note that the search
is much quicker if the relevant Revit sections are already loaded in your Revit prototype
or project before you import your SAP2000 model. For some concrete frame object
properties corresponding to the families listed in Table 2, CSiXRevit creates a new family
type, if it is not already in the new Revit project, and another type of the same family, if
it is already loaded. Therefore if a SAP model includes concrete frame objects, at least
one type of the relevant concrete member families in Revit prototype or project should
be loaded prior to import.
• Frame Releases: See Limitations.
• Insertion Point: Only the insertion points of SAP2000 horizontal area objects are
imported into Revit, as neither Revit columns nor braces have Z-Direction or Lateral
Justification attributes.
• Local Axes: Sets Revit Column Orientation and Beam and Brace Cross-Section Rotation.
The following SAP2000 frame object attributes are not imported into Revit:
• Frame Joint Offsets
• End Length Offsets
Cable Objects
SAP2000 cable area objects are imported into Revit as columns, beams, or braces depending
on whether they are vertical, horizontal, or inclined. Cable area object with “None”
properties or a material that cannot itself be exported are not imported into Revit. The
following SAP2000 cable area object attributes are imported into Revit:
• Name: The SAP2000 name is imported into Revit as a shared parameter.
• Start and End Joints: The coordinates of their start and end joints set the end points of
the Analytical Models of the new Revit columns, beams, and braces.
• Properties: The name of SAP2000 properties is exported. When importing cable area
objects from an .exr files into Revit, CSiXRevit always attempts to locate and load a Revit
family type with the same name.
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Area Objects
SAP2000 area objects are imported into Revit in different ways based on their orientation.
Vertical area objects are imported into Revit as walls. Horizontal area objects are imported
into Revit as floors. Other planar area objects are imported into Revit as floors with a slope.
Non-planar area objects, area objects with “None” properties, or with layered properties,
are not imported into Revit. The following SAP2000 shell and plane attributes are imported
into Revit:
• Name: The SAP2000 name is imported into Revit as a shared parameter.
• Joints: Their coordinates set the corners of the new Revit wall or floor analytical model.
In the case of area objects that are neither vertical nor horizontal, floors with a slope are
created in Revit. Note that while their slope is initially set correctly, Revit subsequently
resets it to a different value. The correct slope is available as a shared parameter named
“Computed slope” and you need to reset the slope of the floor to this parameter value.
• Properties: SAP2000 shell, membrane, plate, and plane properties are imported into
Revit as wall or floor type and as a single layer. The thickness and material matches the
SAP2000 thickness and material. Note that stiffness modifiers are not exported.
Solid Objects, ASolid Objects, Link/SupportObjects, Tendon Objects
SAP2000 Solid objects, ASolid objects, Link/Support objects, and Tendon objects are not
imported into Revit.
Force Joint Loads and Frame object Concentrated Loads
SAP2000 force joint loads and frame object concentrated loads are imported into Revit as
point loads. Not all force joint loads are imported: see Load Pattern and Coordinate System
below. The following SAP2000 force joint load attributes are imported into Revit:
• Load Pattern: It sets the Revit load case name. Loads part of a load pattern that is not
itself exported are not imported into Revit.
• Coordinate System: Joint loads and frame object concentrated loads defined in
coordinate systems other than the local joint coordinate system or the model global
coordinate system are not imported into Revit.
• Force X, Force Y, Force Z, Moment about X, Moment about Y, and Moment about Z: Set
the values of Fx, Fy, Fz, Mx, My, Mz in Revit.
Ground displacement joint loads are not imported into Revit.
Frame object Loads
Frame object distributed loads are imported into Revit as line loads. Distributed loads
consisting of a sequence of trapezoidal loads are imported as multiple loads with one Revit
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line load for each trapezoidal segment. Not all force joint loads are imported: see Load
Pattern and Coordinate System below. The following SAP2000 frame object load attributes
are imported into Revit:
• Load Pattern: It sets the Revit load case name. Loads part of a load pattern that is not
itself exported are not imported into Revit.
• Coordinate System: Frame object distributed loads defined in coordinate systems other
than the local joint coordinate system or the model global coordinate system are not
imported into Revit.
• Load Type, Direction and Load: Set the values of Fx1, Fx2, Fy1, Fy2, Fz1, Fz2, Mx1, Mx2,
My1, My1, My2, Mz1, and Mz2 in Revit. Projected load magnitudes are converted to
absolute load magnitudes based on the geometry of the frame object.
Temperature, strain, target force and internal force frame object loads are not imported into
Revit.
Area Object Loads
Area object uniform, uniform to frame, and surface pressure loads are imported into Revit
as area loads. Not all force joint loads are imported: see Load Pattern and Coordinate
System below. The following SAP2000 area object loads attributes are imported into Revit:
• Load Pattern: It sets the Revit load case name. Loads part of a load pattern that is not
itself exported are not imported into Revit.
• Coordinate System: Area Object distributed loads defined in coordinate systems other
than the local joint coordinate system or the model global coordinate system are not
imported into Revit.
• Load Direction and Load: Set the value of Fx1, Fy1, Fz1, in Revit. Projected load
magnitudes are converted to absolute load magnitudes based on the geometry of the
area object.
Area object temperature loads, strain loads, and pore pressure loads are not imported into
Revit.
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Load Patterns
SAP2000 load patterns with types corresponding to a predefined Revit load case category
are imported into Revit as load cases. The following SAP2000 load pattern attributes are
imported into Revit:
• Load Pattern Name: The same name is used in Revit.
• Load Case Type: It sets the Revit load case nature and category. The mapping is shown in
the following table:
SAP2000 Load Case Type

Revit Load Case
Category
Dead
Live

Dead, Super Dead
Live, Reducible Live,
Pattern Live
Roof Live, Ice
Snow
Wind
Quake
Temperature,
temperature gradient
Other
Not listed above

Roof Live
Snow
Wind
Seismic
Temperature
Not exported
Not exported

Load patterns with types that do not correspond to any predefined Revit load case category
are not imported into Revit, and neither are any of their constituent loads.
Load Cases
If any SAP2000 static linear load case refers to more than one load pattern, than the static
linear load cases are imported into Revit as load combinations, in place of the SAP2000 load
combinations. The following SAP2000 load case attributes are imported into Revit:
• Load Case Name: The same name is used in Revit.
• Load Patterns: Set the list of Revit load cases. Load patterns not imported are not
included in the Revit list.
• Load Pattern Factors: Identical load case factors are used in Revit, unless the load
pattern list includes load patterns that were not exported. Their factors are not imported
into Revit.
SAP2000 load cases that are not static or are not linear are not imported into Revit.
Load Combinations
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If all the SAP2000 static linear load cases each refer to a single load pattern, then the
SAP2000 load combinations are exported as Revit load combinations. When load
combinations are exported, their following attributes are exported:
• Load Combination Name: The same name is used in Revit.
• Load Cases: Sets the list of Revit load cases. The Revit list is made of the load pattern
names that each load case in the SAP2000 list refers to. Load patterns not imported are
not included in the Revit list.
• Load Case Factors: If all the load cases in the list of load cases refer to their load patterns
with a scale factor of 1, the same load case factors are used in Revit. If any load case
refers to a load pattern with a scale factor other than 1, the Revit load case factors are
adjusted accordingly. Scale factors for load patterns not imported are not included.
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Procedures
Exporting from Revit to create a new SAP2000 Model
IMPORTANT NOTE: CSiXRevit only exports the analytical models of Revit elements. All the
analytical models of all Revit elements must be correctly connected to others to ensure the
stability of the SAP2000 model generated.
The following steps describe how to export a Revit analytical model into SAP2000:
1. With Revit running, open a project you want to export.
2. From the Revit menu, select Tools>External Tools>Export to Create New ETABS
or SAP2000 Model.
3. CSiXRevit counts the objects in the Revit project and displays the Export to Create
New ETABS or SAP2000 Model form:

Select the types of elements to send to SAP2000. If you have selected some
objects prior to starting the command and wish to only export those objects,
check the corresponding box at the bottom of the form.
Once you have made your selections, click OK.
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The Exporting to Create New ETABS or SAP 2000 Model message box is shown
and displays the progress of the export:

4. Once the process has run its course, click OK. You are now asked to select a
destination folder and filename. The file will be given the extension .EXR.
5. Start SAP2000 if it is not already running. If it is already running and you want to
retain the changes you made to the current model, save the current model.
SAP2000 always creates a new model when importing an .exr file.
6. Select a SAP2000 unit system. If any issues arise during the import part of the
exchange, SAP2000 generates a log file in which the locations of the problematic
objects are reported in meters if you select metric units, or in feet otherwise.
7. From the menu, select File>Import>Revit Structure .exr File. The Import Revit
Structure .exr file form is displayed. Click the Select EXR File button, and select
the .exr file to import.
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A summary of its contents is displayed:

If any of the framing member family type names in the Revit project do not
match the SAP2000 section profile names listed in AISC13.pro, the form includes
a table listing all unrecognized types:

The default SAP2000 profile selected in the right column for each unrecognized
type in the left column is the closest alphabetical match in AISC13.pro (or
AISC13M.pro depending on the unit system in use when the import began).
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8. Click the Add Sections File button to load additional SAP2000 section properties
databases (.PRO file). Alternately, you can directly edit the default filename in the
field next to the button, pressing the TAB key when you are done. The Revit types
that now have a name match – like C250X30 in the example above – are removed
from the list:

9. For each unknown Revit type in the left column, if the corresponding SAP2000
section profile in the right column is not correct, choose another one from the
drop-down list of predefined profiles:
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“None” SAP properties are always available at the top of the list.
SAP2000 saves your choices in a file which has an .EXRMap extension. Importing
the same Revit project again restores your choices.
10. Select what to import by checking or unchecking the relevant check boxes.
(When checking Area Loads, you will receive a reminder that Area Loads cannot
be imported into the current version of SAP2000.)
11. Click the Import in SAP2000 button.
After a few moments, SAP2000 displays the newly imported model.
12. If any issues arise during the import part of the exchange, you will be prompted
to review the log file.
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Importing from SAP2000 to create a new Revit Project
The following steps describe how to export a SAP2000 model to create a new Revit project:
1. With SAP2000 running, open a model you want to export.
2. Select File>Export>Revit Structure .exr File. The Export Revit Structure .exr File
form is displayed. It includes a summary of the model contents on the left side
and a table with level names on the right side:

Unlike Revit, SAP2000 does not include the concept of story levels because it is a
general purpose analysis program. Therefore, Revit levels need to be created
when a SAP2000 model is imported into Revit. The form gives you control over
which levels are created, their names, their elevations, and how exported
SAP2000 objects are assigned to them in Revit.
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3. If the joints in the SAP2000 model occur at a large number of different z
elevations, you will probably want to create Revit levels only for a small subset of
these elevations. In that case, uncheck the check box at the top of the levels
table. It unchecks all the levels at once:

4. Check the box next to each story level you want created. As you check levels,
SAP2000 computes default cutoff elevations and displays them in the “At or
Below” field. SAP2000 area objects are imported into Revit as walls, floors, or
ramps and SAP2000 frame and cable objects are imported into Revit as columns,
beams or braces. The top and bottom levels of these Revit walls, columns and
braces, and the reference levels of these beams and slabs are assigned based on
the relationship between the level cutoff elevations and the z-coordinates of the
joints defining the original SAP2000 objects.
You can override any cutoff elevation by typing over a new elevation and pressing
the TAB key – as long as you do not set it lower than the corresponding level
elevation, or higher than the elevation of the next level to be created above.
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Likewise, you can rename any level by typing a new name, and change its
elevation by typing a new elevation:

SAP2000 saves your level data in a file which has an .EXRMap extension.
Exporting the same SAP20000 model again restores your level data.
5. Select what to export by checking or unchecking the relevant check boxes.
6. The Metric check box controls the units in which level elevations are displayed,
the family names of the concrete section types created in Revit, and the units of
the log file.
7. By default, the .exr file written is written in the same folder as the model and its
name is the name of the model with an .EXR extension. To save the .exr file in a
different folder or under a different name, click the Save As... button.
Alternately, you can directly edit the default filename in the field next to the
button, pressing the TAB key when you are done.
8. Click the Create EXR File button.
9. If any issues arise during the export part of the exchange, you will be prompted
to review the log file. Please take a moment to do so.
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You are now ready to import the .exr file in Revit. You import an .exr file written by
SAP2000 exactly like an .exr file written by ETABS:
10. Start Revit if it is not already running.
11. Create a new Revit project. Note while it isn’t required, the import will come in
much faster if your Revit template already contains all the column, beam, brace,
slab and wall family types you would like SAP2000 sections to map to.
12. From the menu, select Add-Ins>External Tools>Import to Create New Revit
Project from ETABS or SAP2000. Select the .exr file to import. CSiXRevit attempts
to locate and load family types that are not already loaded.
13. The Import to Create New Revit Project from ETABS/SAP2000 form is displayed:

On the left side, you can control the types of SAP2000 objects to import into the
new Revit project.
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Under Mapping Options, click the Frame Sections button, to see the Frame
Section Mapping form:

Changes to the mapping of SAP2000 sections to Revit sections can be made here.
All Revit column, beam, and brace families currently loaded are displayed in the
drop-down lists.
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Clicking the Floor Sections button displays the Floor Section Mapping form:

Changes to the mapping of SAP2000 floor sections to Revit sections can be made
here. All Revit floor families currently loaded are displayed in the drop-down lists.
Clicking the Wall Sections button displays the Wall Section Mapping form:
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Changes to the mapping of SAP2000 wall sections to Revit sections can be made
here. All Revit wall families currently loaded are displayed in the drop-down lists.
14. Once you have set up all of your mapping, select the OK button. After a few
moments, your Revit project is displayed.
15. If any issues arise during the import part of the exchange, you will be prompted
to review the log file. Please take a moment to do so.
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Known Limitations with CSiXRevit and SAP2000
1. Windows with UAC: With strict UAC (User Account Control), users must “Run as
Administrator” (for SAP2000.exe and Revit.exe). If Revit is not run as administrator,
there is a risk CSiXRevit will not be able to open the .EXRlog file. In this case,
CSiXRevit will not write any warnings to the log file but all warning messages will be
displayed on the screen. Directly sending data to SAP2000 may not work if Revit is
not run as administrator.
2. In the case of area objects that are neither vertical nor horizontal, floors with a slope
are created in Revit. While their slope is initially set correctly, Revit subsequently
resets it to a different value. The correct slope is available as a shared parameter
named “Computed slope” and you need to reset the slope of the floor to this
parameter value.
3. Materials imported into Revit from SAP2000 may not always be properly mapped or
the property values may not always be properly transferred. For this reason, material
mapping and material property values should always be carefully checked in Revit
after importing from SAP2000.
4. See other limitations described in the previous sections for SAP2000.
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Revit and SAFE Data Exchange
Data exchange between CSiXRevit and SAFE supports four different workflows:
5) Exporting from Revit to create a new SAFE model.
6) Exporting from Revit to update an existing SAFE model.
7) Importing from SAFE to create a new Revit project.
8) Importing from SAFE to update an existing Revit project.

Supported Workflows
Exporting from Revit to create a new SAFE model
The table below provides an overview of the data imported in SAFE when exporting from Revit
to create a new SAFE model:
Project Element

Action
Creation of…

Supported

Grid Lines
Story Levels

Notes

Let you select which
horizontal slice of the
project to import.

Materials
Structural Columns and Structural Framing

Steel Column and Framing Family Types
Concrete Column and Framing Family Types

Walls
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Imports only concrete
columns, braces and
beams, and only
columns with
rectangular or circular
section, and only beams
with rectangular
section.

Imports only circular or
rectangular column
sections, and only
rectangular beam
sections.
Slanted walls and walls
with material other
than concrete not
imported.

Wall Family Types

Creates and maps
equivalent SAFE wall
sections.

Wall Openings
Floors

Floors with a filled steel
deck or made of a
material other than
concrete not imported.
Sloped floors with more
than four outer corners
are projected on a
horizontal plane.
Creates and maps
equivalent SAFE slab
and deck sections.

Floor Family Types

Floor Openings
Footings
Point Loads
Line Loads
Area Loads

Non-uniform area loads
not imported.
Creates both a SAFE
load pattern and load
case for each Revit load
case.

Load Cases

Load Combos

Grids
The following Grid attributes are created in SAFE:
• Grid Name: The same grid name is used in the SAFE grid bubble.
• Grid Points: The start and end points are used to define the general grid line in SAFE.
• Curved Grid: The center point, radius, start angle and aperture are used to define the
circular grid line in SAFE.
Materials
The following material attributes are created in SAFE:
• Material Name: The same name is used in SAFE.
• Material Type: The Revit material type is used to identify the SAFE material type, namely
Concrete, Steel or Other.
• Young’s Modulus: The Young’s modulus values from Revit set the SAFE material Young’s
modulus (E). These three values (for the three different directions) cannot be zero in
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•

•

•

•

•
•
•
•
•
•
•
•
•

SAFE. If the first value is zero, then the default SAFE value is used. If any of the remaining
two are zero, then the first non-zero value is used. For an isotropic material, the first
value is used for all other directions.
Poisson’s Ratio: Poisson’s Ratio values from Revit set the SAFE material Poisson’s Ratio
(u). These three values (for the three different directions) cannot be zero in SAFE. If the
first value is zero, then the default SAFE value is used. If any of the remaining two are
zero, then the first non-zero value is used. For an isotropic material, the first value is
used for all other directions.
Shear Modulus: Shear Modulus value from Revit set the SAFE material Shear Modulus
(G). If the Revit material is defined as isotropic, then SAFE calculates this value on the
basis of the Young’s Modulus and the Poisson’s Ratio. In the case of an orthotropic
material, these three values (for the three different directions) cannot be zero in SAFE. If
the first value is zero, then the default SAFE value is used. If any of the remaining two are
zero, then the first non-zero value is used.
Thermal Expansion Coefficient: The thermal expansion coefficient from Revit sets the
SAFE material thermal expansion coefficient (Alpha). These three values (for the three
different directions) cannot be zero in SAFE. If the first value is zero, then the default
SAFE value is used. If any of the remaining two values are zero, then the first non-zero
value is used. For an isotropic material, the first value is used for all other directions.
Weight Density and Mass Density: The unit weight value from Revit sets the SAFE
material weight density (w) and mass density (m). In SAFE, the mass density is calculated
by dividing the weight density by the gravitational constant (g). The weight density
cannot be zero in SAFE. If the unit weight is zero in Revit, then the default SAFE densities
are used.
Damping Ratio: This value is not in used in the current version of SAFE.
Bending Reinforcement: The bending reinforcement value from Revit sets the SAFE
material main reinforcement Fy if the type is concrete. If this value is zero in Revit, then
the default SAFE value is used.
Shear Reinforcement: The shear reinforcement value from Revit sets the SAFE material
shear reinforcement Fy if the type is concrete. If this value is zero in Revit, then the
default SAFE value is used.
Resistance Calculation Strength: The resistance calculation strength from Revit sets the
SAFE material f’c factor. If this value is zero in Revit, then the default SAFE value is used.
Behavior: The Revit behavior tag is used to identify the isotropic or orthotropic materials
in SAFE.
Concrete Compression: The concrete compression value from Revit sets the SAFE
material f’c if the type is concrete.
Lightweight: The Revit lightweight tag is used to identify the lightweight concrete
material in SAFE.
Shear Strength Reduction: This value is not in used in the current version of SAFE.
Yield Stress: This value is not in used in the current version of SAFE.
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•
•

Tensile Strength: This value is not in used in the current version of SAFE.
Steel Reduction Factor: This value is not in used in the current version of SAFE.

Only those materials linked with floors, walls, or frames in the Revit project are imported
into SAFE.
SAFE writes a warning in the .EXRLog file it writes when a default value is used while importing
materials from the Revit project.
Concrete Structural Columns and Framing
The following Revit column and framing element attributes are imported into SAFE:
• Frame Curves: Straight framing elements are imported as straight SAFE frame objects.
Curved framing elements that are not arc shaped are imported as series of short SAFE
objects based on the lines defining their analytical models. Arc shaped beams are
imported as arc shaped SAFE beams.
• Frame End Points and Curves: For straight column and framing elements and curved
framing elements other than arc shaped, the coordinates of the end points of the lines
defining the analytical model of the element are retrieved and SAFE joint objects with
identical coordinates are created. When the analytical model of an element includes rigid
links, the SAFE joint objects are created at the ends of the rigid links with SAFE joints
offsets created to model the link. For arc shaped framing elements, the coordinates of the
end points of the elements themselves are imported instead of the end points of their
analytical models because these analytical models consist of series of short straight
segments and such a tessellation is not required in SAFE. Columns are imported with the
Local Axis 1 always pointing up, and beams and braces with their Local Axis 1 always in
the first quadrant, which means that the end joints may have been switched compared to
the Revit end points.
• Frame Sections: Only columns with rectangular or circular sections and beams with
rectangular sections can be imported.
• End Releases: End releases defined in the element analytical models are imported into
SAFE. SAFE restricts releases that would cause an analytical instability, such as for
example torsion released at both ends. When that happens, SAFE writes a warning in the
.EXRlog file it writes. When SAFE joints have been switched compared to Revit end
points, end releases are also switched.
• Insertion Points: In Revit, the beam insertion point is defined by the following two
parameters:
o Z-Direction Justification
o Lateral Justification
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SAFE calculates the corresponding alignment point on the basis of these two parameters.
If these parameters are not defined for a beam then the default alignment, Top Center, is
chosen. Columns and braces are imported with a Middle Center insertion point.
End Offsets: When the analytical model of an element includes rigid links, these are
imported as end offsets. You can visualize them by looking at the model in extruded view.
In addition, when a beam has its z-Direction Justification parameter set to Other, an
additional vertical offset is created at both ends of the SAFE frame object based on the
value of the z-Direction Offset parameter. Other beam offset parameters such as Start
Level Offset and End Level Offset are not taken into consideration because, except for arc
shaped members, end joints are located based on the end points of the analytical model
which already reflects the values of these parameters. When SAFE joints have been
switched compared to Revit end points, end offsets are also switched.
Orientation Angles: The SAFE Local Axis 2 Angle of columns is computed based on their
rotation as internally stored in Revit. The SAFE Local Axis 2 Angle of beams and braces is
computed based on the value of their Cross-Section Rotation parameter. When SAFE
joints have been switched compared to Revit end points, rotations are adjusted
accordingly.

In-place family members
Revit in-place family members are not imported into SAFE.
Walls
The following wall attributes are imported into SAFE:
• Points: The coordinate of all points defined in the wall analytical model are retrieved and
SAFE joint objects with identical coordinates are created. Revit walls may be defined as
having more than four corners, but SAFE walls can only have three or four nodes. Revit
walls with more than four outer corners are broken into several four node walls, with a
few three node walls when some of the edges are sloped. Also, multi-story walls are
broken into several single story SAFE walls. This is required for reporting and concrete
reinforcement design.
• Wall Curve: Arc shaped curved walls with horizontal bases and tops are imported as SAFE
curved walls. Straight wall edges are imported as such. Other edges are tessellated, with
the degree of approximation defined internally by Revit, and the wall is imported as a
series of walls. Note that when a Revit wall is arc shaped in plane but its top is not
horizontal, its top curve is not an arc and will be tessellated.
• Wall Openings: Wall openings are not imported in SAFE.
• Wall Thickness: A Revit wall has different layers, each having different thickness and
material properties. SAFE only considers the layer with the maximum thickness when
importing the data from Revit.
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Wall Materials: All the materials assigned to the different layers of a Revit wall are
imported into SAFE. However, only one material is assigned to the SAFE wall section
property. Users have the option in SAFE to change the material, if necessary. The
material of the wall layer with the maximum thickness is used.
Slanted walls, with their top not lined up with the base when looked at from above, are not
imported.
Floors
The following floor attributes are imported into SAFE:
• Floor Points: The coordinate of all points defined in the floor analytical model are
retrieved and SAFE joint objects with identical coordinates are created.
• Floor Curves: Floor edges that are arc shaped are imported as arcs in SAFE. Straight floor
edges are imported as such. All other curved floor edges are tessellated, with the degree
of approximation defined internally by Revit. Floors with more than four outer corners
are projected onto a horizontal plane at an elevation matching their average elevation.
• Number of Layers: Floors with a filled steel deck or made of a material other than
concrete cannot be imported. SAFE only considers the layer with the maximum thickness
when importing the data from Revit.
• Layer Thickness: SAFE only considers the layer with the maximum thickness when
importing the data from Revit.
Openings
The following openings are imported into SAFE from Revit:
• Horizontal Openings: These are imported as opening in the floors.
• Wall Openings: These are imported as openings in the walls (vertical planes). For details,
please check Openings in Walls.
• Shaft Openings: These are imported as openings in the floors if their vertical extents
include the story level being imported.
Point Loads
The following point load attributes are imported into SAFE from Revit:
• Load Case Name: It sets the corresponding load case name in SAFE.
• Location: It is used to define the point of application of the load.
• Fx, Fy, Fz, Mx, My, Mz: All forces and moments applied in the global direction, in Revit,
are transferred in a similar manner into SAFE.
If a point load is not directly on top of a SAFE wall, column, or beam, a SAFE beam with None
properties is created to tie the load to the structure.
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Line Loads
The following line load attributes are imported into SAFE from Revit:
• Load Case Name: It sets the corresponding load case name in SAFE.
• Start and End Point Locations: Used to define the start and end point of the line load.
Line loads carrying the gravitational load and overlapping more than one beam are
distributed to the corresponding beams in SAFE. In the case of a lateral line load, users
must check no line load overlaps more than one beam; otherwise it is not processed in
the SAFE analysis.
• Fx, Fy, Fz, Mx, My, Mz: All forces and moments applied in the global direction, in Revit,
are transferred in a similar manner into SAFE. A Revit line load which includes more than
one of these components is imported as several SAFE line loads because SAFE line loads
are unidirectional.
Area Loads
The following area load attributes are imported into SAFE from Revit:
• Load Case Name: It sets the corresponding load case name in SAFE.
• Points: Points are used to define the geometry of the loading area. Curved edges that are
arc shaped are imported as arcs. Straight edges are imported as such. Other edges are
tessellated, with the degree of approximation defined internally by Revit.
• LoadX, LoadY, and LoadZ: All loads applied in the global direction in Revit are transferred
in a similar manner into SAFE.
Non-uniform surface loads are not supported in SAFE and not imported.
Load Cases
The following load case attributes are imported into SAFE from Revit:
• Load Case Name: The same name is used for the SAFE load case.
• Load Case Category: It is used to define the load case type in SAFE. The mapping is
shown in the following table:
Revit Load Case
Category
Dead
Live
Wind
Snow
Roof Live
Accidental
Temperature
Seismic

SAFE Load Case Type
Dead
Live
Wind
Snow
Live
Other
Other
Quake
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Load Combos
The following load combination attributes are imported into SAFE from Revit:
• Load Combination Name: The same name is used for the SAFE Load Combination Name.
• Load Cases: The same load cases list is used in SAFE to define the Load Combination.
• Load Case Factor: The same load case factors are used for the corresponding load cases
in the SAFE load combination.

Exporting from Revit to update an existing SAFE model
The table below provides an overview of the data imported in SAFE when exporting from Revit
to update an existing SAFE model:
Action
Creation of…

Model Element

Supported

Grids
Story Levels
Materials
Frames

Notes

Creates equivalent SAFE materials.
Transfers geometry, offsets, alignment points,
and end releases into SAFE.

Frame Sections
Steel Sections
Concrete Sections
Walls
Wall Properties

Maps to SAFE database sections.
Creates and maps equivalent SAFE sections.

Wall Openings
Floors
Slabs Properties
Floor Openings
Footings

Creates fixed joint restraints in SAFE wherever a
footing occurs in Revit.

Joint Loads
Frame Loads
Shell Loads
Load Cases
Load Combos
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Update of…
Grids
Story Levels
Materials
Frames
Frame Sections
Steel Sections
Concrete Sections
Walls
Wall Properties
Wall Openings
Floors
Slabs Properties
Floor Openings
Point Loads
Line Loads
Area Loads
Load Cases
Load Combos

X
X
X
X
X
Walls with changing number of sides are
replaced.

X
X

.
X
X
Floor openings with changing number of sides
are replaced.
X
X
X
X

Deletion of…
Grids
Story Levels
Frames
Walls
Wall Openings
Floors
Floor Openings
Footings
Point Loads
Line Loads
Area Loads
Load Cases
Load Combos

IMPORTANT NOTE: Deletion of objects when updating a model only works if you are sending
the ENTIRE model. If the “selection only” update feature is used, deletion of items is not
supported.
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Importing from SAFE to create a new Revit Project
The table below provides an overview of the data imported in Revit when creating a new Revit
project:
Action
Creation of…

Model Element

Supported

Grids
Materials

Notes

Imports Concrete and Steel materials into Revit
from SAFE. Limitation is the Revit project should
have one default concrete and one default steel
material for duplication, otherwise the material
will be created in Revit but its parameters will
not be updated, and the properties of the new
materials are identical to those of the template
materials.

Frames
Frame Sections
Concrete Sections

Creates and maps equivalent Revit sections.
See mapping below.
Slanted walls not imported.

Walls
Wall Properties
Wall Openings
Floors
Slabs Properties
Footings
Load Cases
Joint Loads
Frame object Loads

Creates equivalent Revit point line loads and
trapezoidal line loads.
Creates equivalent Revit area loads.

Surface Loads
Load Combos
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Mapping of SAFE section types to Revit families:
Columns
SAFE
Rectangular
Square
Circular

Revit Family
Concrete-Rectangular-Column.rfa
Concrete-Square-Column.rfa
Concrete-Round-Column.rfa

Beams and Braces
SAFE
Rectangular or Square

Revit Family
Concrete-Rectangular Beam.rfa
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Importing from SAFE to Update an Existing Revit Project
The table below provides an overview of the data imported in Revit when updating an existing
Revit project:
Action
Creation of…

Model Element

Supported

Grids
Story Levels
Materials
Frames
Frame Sections
Steel Sections
Concrete Sections

Notes

Creates and maps equivalent Revit sections.
See mapping at end of previous section.

Walls
Wall Properties
Wall Openings
Floors
Slabs Properties
Deck Properties
Floor Openings
Footings
Load Cases
Joint Loads
Line Loads
Area Loads
Load Combos
Update of…
Grids
Story Levels
Materials
Frames

Updates changes to column locations only for
columns not meshed in SAFE and with a 1:1
correspondence between Revit and SAFE. You can
choose between leaving columns meshed in SAFE
in their original Revit locations and replacing
them with the SAFE meshed columns.

Frame Sections
Steel Sections
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Concrete Sections

Updates Beam, Column and Brace section
assignments; however section parameters
themselves do not update. If you would like to
bring in the changes to the parameters from
SAFE, create a new section with the desired
parameters in SAFE and assign the new section to
the frame.
Updates changes in wall location only for walls
not meshed in SAFE and with a 1:1
correspondence between Revit and SAFE. You can
choose between leaving walls meshed in SAFE in
their original Revit locations and replacing them
with the SAFE meshed walls.
Updates wall type assignments; however wall
types themselves do not update. If a wall section
is changed in SAFE, it is imported under a new
name in Revit.
Non-rectangular wall openings are not updated.
Replaces floors which moved, were not meshed
when brought in from SAFE, and with a 1:1
correspondence between Revit and SAFE. You can
choose between leaving floors meshed in SAFE in
their original Revit locations and replacing them
with the SAFE meshed floors.

Walls

Wall Properties

Wall Openings
Floors

Slabs Properties

Updates floor type assignments; however floor
types themselves do not update. If a floor section
is changed in SAFE, it is imported under a new
name in Revit.
Floor openings moved in SAFE are replaced.

Deck Properties
Floor Openings
Load Cases
Point Loads
Line Loads
Area Loads
Load Combos

Area loads moved in SAFE are replaced.

Deletion of…
Grids
Story Levels
Materials
Frames
Walls
Wall Openings
Floors

Non-rectangular wall openings are not deleted.
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Floor Openings

Floor openings imported as a floor shaft and
deleted in SAFE are not deleted.

Load Cases
Point Loads
Line Loads
Area Loads
Load Combos

IMPORTANT NOTE: Deletion of objects when updating a model only works if you are sending
the ENTIRE model. If the “selection only” update feature is used, deletion of items is not
supported.
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Procedures
Exporting from Revit to Create/Update a New/Existing SAFE Model
IMPORTANT NOTE: CSiXRevit only exports the analytical models of Revit elements. All the
analytical models of all Revit elements must be correctly connected to others to ensure the
stability of the SAFE model generated. Walls, columns, beams, and floors of a material type
other than concrete are not imported in SAFE, and neither are columns with a section other
than circular or rectangular, and beams with a section other than rectangular.
The following steps describe how to send your Revit analytical model to SAFE:
1. To create a new SAFE model, from the Revit menu select, Tools>External
Tools>Export to Create New ETABS or SAP2000 Model. To update an existing
SAFE model, from the Revit menu, select Tools>External Tools>Export to Update
Existing ETABS or SAFE Model.
2. CSiXRevit counts the elements in the Revit project and displays the Export to
Create New ETABS, SAP2000, or SAFE Model form, or Export to Update Existing
Model form as may be the case:

Select the categories of Revit elements to export to SAFE. If you have selected
some elements prior to starting the command and wish to only export those
elements, check the corresponding box at the bottom of the form.
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SAFE analyzes horizontal single level structures but you do not need to select
Revit elements from a single level. You will choose a level to import in the next
step.
Once you have made your selections, click OK.
The Exporting to Create New ETABS SAP 2000 or SAFE Model or Exporting to
Update Existing ETABS or SAFE model information message box is shown and
displays the progress of the export:

3. Once the process has run its course, click OK. You are now asked to select a
destination folder and filename. The file will be given the extension .EXR.
4. Start SAFE if it is not already running.
5. To create a new SAFE model from your Revit project, you should not have any
other model open. By default SAFE creates a new model based on your .EXR file.
To update an existing SAFE model, open it.
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6. From the menu, select File>Import>EXR Revit file, and then select the .EXR file to
import. The Import .EXR File form is displayed:

The form displays the contents of the EXR file. Again, you can choose which
categories of Revit elements to import or update. If the Revit project has multiple
stories you can choose a story to import – or all of them in the case the structure
is essentially plane and the story distinctions are not relevant. You can also
specify a model Z offset so that the imported floor slabs and beams will be at the
zero elevation - making it easier to work with in SAFE.
7. Once satisfied with the mapping parameters, in the Revit Data Overview/Controls
form select OK. The SAFE model is created.
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Exporting from SAFE to Create/Update a New/Existing Revit Project
The following steps describe how to export your SAFE model to create or update a Revit project:
1. Once you have edited, analyzed and designed your structure in SAFE, save the
SAFE file by selecting the File>Save.
2. In SAFE, select File>Export Model>EXR File and specify a destination folder and
filename in the form which is displayed.
3. The Export .EXR file form is displayed. It shows a count of the SAFE objects
available for export. If the model was previously imported from Revit with a
model offset other than zero, the opposite Project Z Offset is set by default. If
you have selected parts of the model, and would like to send only those
selections, check the Selected Objects Only box.

4. Start Revit if it is not already running.
5. To create a new Revit project from your SAFE model, open a Revit template that
you would like to import your SAFE model into. From the Revit menu, select
Tools>External Tools>Import to Create New Revit Project from ETABS, SAP2000
or SAFE. Select the .exr file you would like to import. CSiXRevit will try to load any
required families that are not already loaded.
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To update an existing Revit project, first open it. From the Revit menu select,
Tools>External Tools>Import to Update Existing Revit Project from ETABS or
SAFE. Select the .exr file to import.
6. Whether creating a new Revit project or updating an existing Revit project, after
selecting the .EXR file, the following form is displayed:

On the left side, you can control the types of SAFE objects to import into the
Revit project and the mapping of SAFE sections to Revit types.
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Clicking the Frame Sections button under “Mapping Options” displays the Frame
Section Mapping form:

Changes to the mapping of SAFE sections to Revit sections can be made here. All
Revit column beam and brace families currently loaded are displayed in the drop
down lists.
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Clicking the Floor Sections button displays the Floor Section Mapping form:

Changes to the mapping of SAFE floor sections to Revit sections can be made
here. All Revit floor families currently loaded are displayed in the drop down lists.
Clicking the Wall Sections button displays the Wall Section Mapping form:
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Changes to the mapping of SAFE wall sections to Revit sections can be made
here. All Revit wall families currently loaded are displayed in the drop down lists.
If you are updating a Revit project from a SAFE model, you have the choice to
update locations and releases, designs and load magnitudes, or both:

Also, when updating a Revit project from a SAFE model, there can be instances in
which the 1:1 mapping of Revit elements to SAFE objects is lost because objects
in SAFE were meshed. If this is the case, you have two options:
1. Delete the existing Revit elements, and have CSiXRevit create new
instances that are meshed in SAFE.
2. Keep the existing elements as they are and use the Objects button to
display a form that lets you control the assignment of section properties
of mapped objects during the import.
Once satisfied with the object mappings, select OK and the SAFE model will be
imported.
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Reviewing the Log File (.EXRlog)
Every time a model is sent from Revit to ETABS or from SAFE to Revit, a file with the
extension .EXRlog is created if it does not exist, or appended if it already exists. This file
lists the project or model name, the workflow operation, and the time and date. It also
lists any errors or omissions encountered in generating or importing the .EXR file, and
therefore, should be checked every time data is transferred. The .EXRlog file also lists the
build numbers for CSiXRevit and Revit. The two should be identical to ensure no
misinterpretation of data occurred. The first few lines of the .log file have the following
format (the actual data may be different):
CSixRevit Revit API Version = 2019.0
CSixRevit Build = 20180216_1515(x64)
Current Revit Version = 2019.0
Current Revit Build = 20180216_1515(x64)

The “Build =” numbers should be the same – having the same Version numbers but
different Build numbers does not guarantee data consistency.
Additionally, in the case of an incremental import, the changes made to the Revit project
are listed.
Added Area Load for the following elements:
262405 to replace 262161
262422 to replace 262188
262439 to replace 262205
262456 to replace 262222
262473 to replace 262239
262490 to replace 262256
Added Floor for the following elements:
262383 to replace 262086
262393 to replace 262117
262401 to replace 262125
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Each Revit element is identified by its “Revit ID”. You can view the elements the IDs refer
to by selecting Manage>Select by ID in the Revit ribbon, typing an ID, and clicking the
Show button:

Revit will find a view that shows the element, switch to that view, and highlight the element.

Known Limitations with CSiXRevit and SAFE
1. If your version of Windows includes strict UAC (User Account Control), you need to run
SAFE.exe and Revit.exe with the option “Run as Administrator”. If Revit is not run as
administrator, there is a risk CSiXRevit will not be able to open the .EXRlog file. In this
case, CSiXRevit will not write any warnings to the log file but all warning messages will be
displayed on the screen.
2. Revit floors that are grouped together may be classified as openings when imported in
SAFE.
3. Materials imported into Revit from SAFE may not always be properly mapped or the
property values may not always be properly transferred. For this reason, material
mapping and material property values should always be carefully checked in Revit after
importing from SAFE.
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